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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This guide examines the effects of using a non-conformal mesh rather than a conformal mesh in
a simple pin-fin heat-sink problem. In the guide, you will learn how to:

l Generate a non-conformal mesh and related parameters such as slack values, maximum
element sizes, and so on.

l Understand the effects of a non-conformal mesh on total mesh count and results.
l Generate and compare summary reports.
l Apply non-conformal rules and restrictions.
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2 - Open the Project and Review the
Model

After launching the Ansys Electronics Desktop, create a project, insert an Icepak design, and
build the model.

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Getting Started with Icepak®: Non-Conformal Mesh
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the file NonConformalMesh.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Review the Model
The model consists of a pin-fin heat sink composed of aluminum, which is in contact with a
source dissipating 10W, as shown below. The source-heatsink assembly sits in the middle of a

Open the Project and Review the Model 2-2
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wind tunnel with a wind speed of 1.0 m/s. The ambient temperature is 20°C, and the flow regime
is turbulent.

The objective of this exercise is to become familiar with the non-conformal meshing meth-
odology and its application. You will examine and compare the solution results of a conformal
and a non-conformal mesh.

In Icepak, you can assign mesh regions. First, you define a region around a component. Icepak
meshes this region independently of the external global mesh region.

Sample Project - Pin-Fin Heatsink

Figure 2-1: Pin-Fin Heatsink

Open the Project and Review the Model 2-3
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3 - Assign Boundary Conditions
In this model, assign boundary conditions and define thermal and flow properties for an opening,
a grille ,and a source.

Assign an Opening
1. In the History tree, expandModel > Sheets > Opening and select cabinet_default_

side_minz.
2. In the 3D Modeler window, right-click and select Assign Thermal > Opening > Free.
3. In theOpening Thermal Model dialog box under Flow Specification, select Velocity.
4. For Z Velocity, enter 1 and retainm_per_sec as the unit.
5. ClickOK.

Assign a Grille
1. Press F to enter face selection mode.
2. In the 3D Modeler window, select the cabinet_default_side_maxz face as shown below.

3. Right-click and select Assign Thermal > Grille.
4. In theGrille Thermal Model dialog box under Flow Specification, select Loss Coef-

ficient for the Pressure Loss Type.
5. For Free Area Ratio, enter 0.8.

Getting Started with Icepak®: Non-Conformal Mesh
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6. For Resistance Type, select Perforated Thin Vent.
7. ClickOK.

Assign a Source
1. PressO to enter object selection mode.
2. In the 3D Modeler window, with the cursor above the source geometry, click the cabinet

and then press B to select the geometry behind the cabinet.

3. Right-click and select Assign Thermal > Source.
4. In the Source Thermal Model dialog box under Thermal Specification, select Total

Power for the Thermal Condition.
5. For Total Power, enter 30 and selectW as the unit.
6. ClickOK.

Assing Boundary Conditions 3-2
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4 - Create a Heatsink
Create a heatsink to disperse heat away from the source object.

1. In the Project Manager, right-click 3D Components.
2. From the right-click menu, select Create > Heatsink.
3. In the Heatsink Component dialog box, click theGeometry tab and define the following

parameters:
l Plane: ZX
l Overall height: 0.1 meter

4. Under Base, define the following parameters:
l Length: 0.2 meter
l Width: 0.08 meter
l Height: 0.02 meter

5. Under Fin, define the following parameters:
l Type: CrossCutExtrusion
l Flow Direction: Z
l Count (Z:) 8
l Count (X): 8
l Thickness (Z): 0.01 meter
l Thickness (X): 0.004 meter
l Offset (Z): 0 meter
l Offset (X): 0 meter

6. Click the Properties tab and review the material assignments for the Heatsink fins and
base. Al-Extruded is the assigned solid material, and Steel-oxidised-surface is the
assigned surface material.

7. ClickOK.

Position the Heatsink
1. If not already selected, select the heatsink in the Project Manager under

3D Components.
2. From the Editmenu, select Arrange > Move.
3. Press the F4 key to display theMove dialog box.
4. In theMove dialog box, enter 0.5 ,0.5 ,0.5 meter for theMove Vector Value and Unit.

Getting Started with Icepak®: Non-Conformal Mesh
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5. ClickOK.

Create a Heatsink 4-2
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5 - Generate a Conformal Mesh
Generate a conformal mesh for the model.

1. On the Simulation ribbon tab, clickGlobal Mesh Settings.
2. In theMesh Region dialog box, click the Advanced tab.
3. Enable User specified and define the global mesh settings as displayed in the image

below.

4. ClickOK.
5. On the Simulation ribbon tab, clickGenerate Mesh. After the mesh is generated, the

Mesh Visualization dialog box appears.

View the Conformal Mesh
1. On the View ribbon tab, click theOrient drop-down list and select Front.
2. In theMesh Visualization dialog box underMesh display on, enable Show.
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3. Under Plane Location, select Y plane through center for Define plane.

4. Click Close.

Generate a Conformal Mesh 5-2
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6 - Set Up the Solution
Create a monitor point for the source and define the solution settings.

Create a Monitor Point
1. In the Project Manager under Thermal, right-click Source1 and select Select Assign-

ment.
2. In the 3D Modeler window, right-click and select Assign Monitor > Point.
3. In theMonitor Setup dialog box, expand Thermal and select Temperature.
4. ClickOK.

Create a Solution Setup
1. In the Project Manager, right-click Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup dialog boxGeneral tab, enter 300 for theMaximum Number

of Iterations.
3. Under Flow Regime, select Turbulent.
4. Click Options to open the Turbulent Flow Model dialog box.
5. Select Zero Equation and clickOK.
6. On the Solver Settings tab, enter 1 m_per_sec for Z Velocity to speed up the con-

vergence by initializing the solver.
7. Click Advanced Options to open the Advanced Solver Settings dialog box.
8. Enter the following Under-relaxation values:

l Pressure: 0.7
l Momentum: 0.3
l Temperature: 1

9. ClickOK to close the Advanced Solver Settings dialog box.
10. Click OK to close Icepak Solve Setup dialog box.

Save the Project
From the Filemenu, select Save.
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7 - Run the Simulation and Examine the
Results

Run the Conformal Mesh Simulation
1. In the Project Manager, expand Analysis.
2. Right-click Setup1 and select Analyze.
3. Right-click Setup1 and select Residual to monitor the simulation while the solver runs.

4. Click the Thermal Monitor tab to view the temperature data for the monitor point on the

Getting Started with Icepak®: Non-Conformal Mesh

Run the Simulation and Examine the Results 7-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Non-Conformal Mesh

source.

Examine the Results
Create a Fields Summary report to view the thermal data for the source and heatsink.

1. On the Results ribbon tab, click Fields Summary.
2. In the Setup Calculation dialog box, selectObject for the Entity Type.
3. Report the temperature data for the source :

l Under Entity, select source_1.
l UnderQuantity, select Temperature.
l Click Add As Single Calculation.

4. Report the temperature data for the heatsink :
l Under Entity, select all of the heatsink objects.
l UnderQuantity, select Temperature.
l Click Add As Single Calculation.

5. In the Fields Summary dialog box, minimum, maximum, and mean temperatures for the

Run the Simulation and Examine the Results 7-2
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heat sink and source are displayed. Note the maximum temperature for both objects.
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8 - Assign a Mesh Region
Create a mesh region surrounding the source object and heatsink to create a non-conformal
mesh.

1. In the History tree, expandModel > assembly_1 > Sheets > Source and select source_
1.

2. ExpandModel> Heatsink1.
3. Hold Ctrl and select Heatsink1_1.
4. In the 3D Modeler window, right-click and select Assign Mesh Region.
5. On the SubRegion dialog box, select Pad individual directions for Padding Data.
6. For each Direction, select Absolute Offset from the Padding type drop-down and enter

the following values.
l +X: 0.05 meter
l -X: 0.05 meter
l +Y: 0.05 meter
l -Y: 0 meter
l +Z: 0.15 meter
l -Z: 0.05 meter

7. On theMesh Region dialog box Advanced tab, enable User specified.UnderMaximum
Element Size, enter the following values:

l X: 0.01 meter
l Y: 0.01 meter
l Z: 0.25 meter

8. UnderMinimum Gap, enter the following values:
l X: 8.9e-05 meter
l Y: 8.9e-05 meter
l Z: 5e-06 meter

9. UnderMulti level meshing:

l Disable Enable.
l Disable Uniform mesh parameters.
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Assign a Mesh Region 8-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Non-Conformal Mesh

10. ClickOK.
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9 - Generate a Non-Conformal Mesh
With the mesh region created, generate a non-conformal mesh for the model. On the Sim-
ulation ribbon tab, clickGenerate Mesh. After the mesh is generated, theMesh Visualization
dialog box appears.

View the Non-Conformal Mesh
1. On the View ribbon tab, click theOrient drop-down list and select Front.
2. In theMesh Visualization dialog box underMesh display on, enable Show.
3. Under Plane Location, select Y plane through center for Define plane. Note the

clustered mesh lines extending from the heat sink all the way across the domain in both
the and directions only within the bounds of the mesh region.

4. Click Close.
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10 - Run the Simulation and Examine
the Results

Run the Non-Conformal Mesh Simulation
1. In the Project Manager, expand Analysis.
2. Right-click Setup1 and select Analyze.
3. Right-click Setup1 and select Residual to monitor the simulation while the solver runs.

With the non-conformal mesh, the simulation converges in fewer iterations.

4. Click the Thermal Monitor tab to view the temperature data for the monitor point on the

Getting Started with Icepak®: Non-Conformal Mesh
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source.

Examine the Results
1. On the Results ribbon tab, click Fields Summary.
2. In the Fields Summary dialog box, the data is updated with the new solution data. Note

that the maximum temperatures for both objects are very close to those obtained in the

Run the Simulation and Examine the Results 10-2
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simulation with the conformal mesh.
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11 - Summary
In this tutorial, you generated both a conformal and a non-conformal mesh for a simple source-
heatsink geometry and compared the two sets of results. You found a reduction in the number of
cells for the non-conformal mesh with a negligible change in the temperature data. In the pro-
cess, you learned how to create a mesh region with slack values to create an appropriate bound-
ing box for your separately meshed region.

The following are some best practices:

l Reduce mesh counts and consequently decrease run times by creating mesh regions that
require a different mesh density. Also select suitable slack values that improve the con-
vergence rate while avoiding mesh bleeding.

l Increase slack values for faces with a wake region if using a mesh region. Do this to cap-
ture the wake more accurately.

l Create monitor points of relevant quantities (temperature, pressure, or velocity) to help
judge convergence alongside residuals.

l Initialize the solution with reasonable values to achieve faster convergence.

Getting Started with Icepak®: Non-Conformal Mesh

Summary 11-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.


	Table of Contents
	1 - Introduction
	2 - Open the Project and Review the Model
	Launch the Ansys Electronics Desktop
	Set 3D UI Options
	Open the Project
	Review the Model

	3 - Assign Boundary Conditions
	Assign an Opening
	Assign a Grille
	Assign a Source

	4 - Create a Heatsink
	Position the Heatsink

	5 - Generate a Conformal Mesh
	View the Conformal Mesh

	6 - Set Up the Solution
	Create a Monitor Point
	Create a Solution Setup
	Save the Project

	7 - Run the Simulation and Examine the Results
	Run the Conformal Mesh Simulation
	Examine the Results

	8 - Assign a Mesh Region
	9 - Generate a Non-Conformal Mesh
	View the Non-Conformal Mesh

	10 - Run the Simulation and Examine the Results
	Run the Non-Conformal Mesh Simulation
	Examine the Results

	11 - Summary

